diff options
author | Sergey Vlasov <[email protected]> | 2021-08-30 00:24:43 +0300 |
---|---|---|
committer | GitHub <[email protected]> | 2021-08-29 22:24:43 +0100 |
commit | a1866a962c21a6e15f40cbde2bd09c0ff42f1454 (patch) | |
tree | a9703c68d3ae4bae352d0e7cb827acd1f3474cd7 /shell.nix | |
parent | ef7fdee6c803bf92bd6d892326c05ee1f473ad07 (diff) | |
download | qmk_firmware-a1866a962c21a6e15f40cbde2bd09c0ff42f1454.tar.gz qmk_firmware-a1866a962c21a6e15f40cbde2bd09c0ff42f1454.zip |
Update the nix-shell environment (#13316)0.14.2
* Nix: Allow calls to `bin/qmk` even when the build was started by `qmk`
The `$PATH` modifications performed by the Nix wrapper for the `qmk`
executable prevent `bin/qmk` from working properly (the changed `$PATH`
contains a wrong `python3` executable which does not have the needed
Python modules in its module path). As a workaround, disable the
generation of that wrapper for the `qmk` Python package (there is yet
another wrapper generated while building the Python environment, which
would still set the Python module path properly when running `qmk`).
Although `bin/qmk` is officially deprecated, QMK CLI still invokes it in
some cases (at least `qmk doctor` and `qmk pytest`), therefore keeping
these invocations working is useful.
* Nix: Update `util/nix/pyproject.toml` to match `requirements*.txt`
Update the Python dependency information used by Poetry to match the
current state of the qmk_firmware code.
* Nix: Bump QMK CLI dependency to 1.0.0; bump other Python deps
Update Python dependencies for nix-shell to the most recent releases:
- dotty-dict: 1.3.0 -> no longer used
- milc: 1.4.2 -> 1.6.2
- pep8-naming: 0.11.1 -> 0.12.1
- pygments: 2.9.0 -> 2.10.0
- pyrsistent: 0.17.3 -> 0.18.0
- pyusb: 1.1.1 -> 1.2.1
- setuptools-scm: 6.0.1 -> no longer used
- qmk: 0.1.0 -> 1.0.0
- qmk-dotty-dict: not used -> 1.3.0.post1
- yapf: 0.30.0 -> 0.31.0
Note to self: The command to update Python dependencies changed to:
( cd util/nix && nix run 'nixpkgs#poetry' -- update --lock )
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -12,6 +12,13 @@ let # files if the requirements*.txt files change pythonEnv = poetry2nix.mkPoetryEnv { projectDir = ./util/nix; + overrides = poetry2nix.overrides.withDefaults (self: super: { + qmk = super.qmk.overridePythonAttrs(old: { + # Allow QMK CLI to run "bin/qmk" as a subprocess (the wrapper changes + # $PATH and breaks these invocations). + dontWrapPythonPrograms = true; + }); + }); }; in |