aboutsummaryrefslogtreecommitdiff
path: root/keyboards/cannonkeys/gentoo
diff options
context:
space:
mode:
authorJames Young <[email protected]>2024-04-11 08:29:10 -0700
committerGitHub <[email protected]>2024-04-11 16:29:10 +0100
commita532d1cc5a785da3d73812330aad95555efb81fa (patch)
tree7368acf53a6c68748e64a9ee02add119c338fb18 /keyboards/cannonkeys/gentoo
parent8bbbe753fdaf006d0f932187eac788b89910437d (diff)
downloadqmk_firmware-a532d1cc5a785da3d73812330aad95555efb81fa.tar.gz
qmk_firmware-a532d1cc5a785da3d73812330aad95555efb81fa.zip
Data-driven Keyboard Conversions: C (#23453)
Diffstat (limited to 'keyboards/cannonkeys/gentoo')
-rw-r--r--keyboards/cannonkeys/gentoo/info.json8
-rw-r--r--keyboards/cannonkeys/gentoo/rules.mk14
2 files changed, 8 insertions, 14 deletions
diff --git a/keyboards/cannonkeys/gentoo/info.json b/keyboards/cannonkeys/gentoo/info.json
index a371ae4232..3d8a4acac9 100644
--- a/keyboards/cannonkeys/gentoo/info.json
+++ b/keyboards/cannonkeys/gentoo/info.json
@@ -19,6 +19,14 @@
},
"processor": "STM32F072",
"bootloader": "stm32-dfu",
+ "features": {
+ "bootmagic": true,
+ "mousekey": true,
+ "extrakey": true,
+ "console": true,
+ "command": true,
+ "nkro": true
+ },
"community_layouts": [
"65_ansi",
"65_ansi_split_bs",
diff --git a/keyboards/cannonkeys/gentoo/rules.mk b/keyboards/cannonkeys/gentoo/rules.mk
index 480e866179..0ab54aaaf7 100644
--- a/keyboards/cannonkeys/gentoo/rules.mk
+++ b/keyboards/cannonkeys/gentoo/rules.mk
@@ -1,16 +1,2 @@
# Wildcard to allow APM32 MCU
DFU_SUFFIX_ARGS = -v FFFF -p FFFF
-
-# Build Options
-# change yes to no to disable
-#
-BOOTMAGIC_ENABLE = yes # Enable Bootmagic Lite
-MOUSEKEY_ENABLE = yes # Mouse keys
-EXTRAKEY_ENABLE = yes # Audio control and System control
-CONSOLE_ENABLE = yes # Console for debug
-COMMAND_ENABLE = yes # Commands for debug and configuration
-NKRO_ENABLE = yes # Enable N-Key Rollover
-BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
-RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
-AUDIO_ENABLE = no # Audio output
-