aboutsummaryrefslogtreecommitdiff
path: root/keyboards/dm9records/plaid/keymaps
Commit message (Collapse)AuthorAgeFilesLines
* Non-volatile memory data repository pattern (#24356)Nick Brassel2025-03-211-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * First batch of eeconfig conversions. * Offset and length for datablocks. * `via`, `dynamic_keymap`. * Fix filename. * Commentary. * wilba leds * satisfaction75 * satisfaction75 * more keyboard whack-a-mole * satisfaction75 * omnikeyish * more whack-a-mole * `generic_features.mk` to automatically pick up nvm repositories * thievery * deferred variable resolve * whitespace * convert api to structs/unions * convert api to structs/unions * convert api to structs/unions * fixups * code-side docs * code size fix * rollback * nvm_xxxxx_erase * Updated location of eeconfig magic numbers so non-EEPROM nvm drivers can use them too. * Fixup build. * Fixup compilation error with encoders. * Build fixes. * Add `via_ci` keymap to onekey to exercise VIA bindings (and thus dynamic keymap et.al.), fixup compilation errors based on preprocessor+sizeof. * Build failure rectification.
* Update keymaps to use PDF keycode (#24633)Joel Challis2024-11-231-23/+5
|
* Remove all via-enabled keymaps, including `via`. (#24322)Nick Brassel2024-08-264-116/+0
|
* Update GPIO macros in keymaps (#23792)Ryan2024-05-242-18/+18
|
* Remove obvious user keymaps, `keyboards/{d,e,f}*` edition. (#22695)Nick Brassel2023-12-1811-1280/+0
|
* Add `mousekey.h` include to `quantum.h` (#21897)Ryan2023-09-041-2/+0
|
* VIA Protocol 12 + fixes (#19916)Nick Brassel2023-02-231-2/+2
| | | | | Co-authored-by: Wilba <[email protected]> Co-authored-by: zvecr <[email protected]>
* Refactor some layouts which contain keyboard name (#19645)Joel Challis2023-01-202-11/+11
| | | | | * Refactor some layouts which contain keyboard name * use planck_mit
* Update use of legacy keycodes (#19120)Joel Challis2022-11-223-6/+6
|
* Normalise Space Cadet keycodes (#18864)Ryan2022-10-272-4/+4
|
* Remove legacy keycodes, part 5 (#18710)Ryan2022-10-151-1/+1
| | | | | * `KC_SLCK` -> `KC_SCRL` * `KC_NLCK` -> `KC_NUM`
* Remove legacy keycodes, part 3 (#18669)Ryan2022-10-111-2/+2
| | | | | | | | | * `KC__VOLDOWN` -> `KC_VOLD` * `KC__VOLUP` -> `KC_VOLU` * `KC__MUTE` -> `KC_MUTE` * `KC_POWER` -> `KC_PWR`
* Remove remaining use of terminal keys and related comment labels (#18402)Johannes Löthberg2022-09-292-2/+2
|
* Use a macro to compute the size of arrays at compile time (#18044)Jeff Epler2022-08-303-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add ARRAY_SIZE and CEILING utility macros * Apply a coccinelle patch to use ARRAY_SIZE * fix up some straggling items * Fix 'make test:secure' * Enhance ARRAY_SIZE macro to reject acting on pointers The previous definition would not produce a diagnostic for ``` int *p; size_t num_elem = ARRAY_SIZE(p) ``` but the new one will. * explicitly get definition of ARRAY_SIZE * Convert to ARRAY_SIZE when const is involved The following spatch finds additional instances where the array is const and the division is by the size of the type, not the size of the first element: ``` @ rule5a using "empty.iso" @ type T; const T[] E; @@ - (sizeof(E)/sizeof(T)) + ARRAY_SIZE(E) @ rule6a using "empty.iso" @ type T; const T[] E; @@ - sizeof(E)/sizeof(T) + ARRAY_SIZE(E) ``` * New instances of ARRAY_SIZE added since initial spatch run * Use `ARRAY_SIZE` in docs (found by grep) * Manually use ARRAY_SIZE hs_set is expected to be the same size as uint16_t, though it's made of two 8-bit integers * Just like char, sizeof(uint8_t) is guaranteed to be 1 This is at least true on any plausible system where qmk is actually used. Per my understanding it's universally true, assuming that uint8_t exists: https://stackoverflow.com/questions/48655310/can-i-assume-that-sizeofuint8-t-1 * Run qmk-format on core C files touched in this branch Co-authored-by: Stefan Kerkmann <[email protected]>
* RESET -> QK_BOOT user keymaps (#17940)Joel Challis2022-08-214-5/+5
|
* Make default layer size 16-bit (#15286)Drashna Jaelre2022-06-191-1/+1
| | | Co-authored-by: James Young <[email protected]>
* Removes terminal from QMK. (#17258)Nick Brassel2022-05-301-1/+1
|
* RESET -> QK_BOOT default keymaps (#17037)Joel Challis2022-05-151-1/+1
|
* Remove empty config.h from default-ish keymaps (#15429)Ryan2021-12-091-19/+0
|
* [Bug] Develop - Change uint32_t to layer_state_t (#13596)Xelus222021-07-192-4/+4
| | | | | * fix sat75 * update uint32_t to layer_state
* Enable extrakeys, mousekeys for all VIA keymaps. (#10740)kaylanm2020-11-021-2/+0
|
* [Keymap] add an autoclicker to my plaid keymap (#10743)Benjamin Grosse2020-10-292-2/+31
|
* [Keymap] plaid keymap with custm LED animation (#10701)Benjamin Grosse2020-10-232-0/+205
|
* Add stephen-huan keymap and fix LED problem in the default Plaid keymap (#9306)Stephen Huan2020-09-194-0/+380
| | | | | | | | | | | | | | | | | * change layers, add pinmode to fix LEDs * fix LEDs by setting the pin mode * edit README * edit GPIO documentation, edit keymap * add markov chain * simplify LED logic * undo documentation changes * keymap changes, fix LED enum logic
* Move plaid via keymap to correct location (#9255)0.9.1Joel Challis2020-06-014-0/+118
|
* 2020 May 30 Breaking Changes Update (#9215)0.9.0James Young2020-05-309-0/+1136
* Branch point for 2020 May 30 Breaking Change * Migrate `ACTION_LAYER_TOGGLE` to `TG()` (#8954) * Migrate `ACTION_MODS_ONESHOT` to `OSM()` (#8957) * Migrate `ACTION_DEFAULT_LAYER_SET` to `DF()` (#8958) * Migrate `ACTION_LAYER_MODS` to `LM()` (#8959) * Migrate `ACTION_MODS_TAP_KEY` to `MT()` (#8968) * Convert V-USB usbdrv to a submodule (#8321) * Unify Tap Hold functions and documentation (#8348) * Changing board names to prevent confusion (#8412) * Move the Keyboardio Model01 to a keyboardio/ subdir (#8499) * Move spaceman keyboards (#8830) * Migrate miscellaneous `fn_actions` entries (#8977) * Migrate `ACTION_MODS_KEY` to chained mod keycodes (#8979) * Organizing my keyboards (plaid, tartan, ergoinu) (#8537) * Refactor Lily58 to use split_common (#6260) * Refactor zinc to use split_common (#7114) * Add a message if bin/qmk doesn't work (#9000) * Fix conflicting types for 'tfp_printf' (#8269) * Fixed RGB_DISABLE_AFTER_TIMEOUT to be seconds based & small internals cleanup (#6480) * Refactor and updates to TKC1800 code (#8472) * Switch to qmk forks for everything (#9019) * audio refactor: replace deprecated PLAY_NOTE_ARRAY (#8484) * Audio enable corrections (2/3) (#8903) * Split HHKB to ANSI and JP layouts and Add VIA support for each (#8582) * Audio enable corrections (Part 4) (#8974) * Fix typo from PR7114 (#9171) * Augment future branch Changelogs (#8978) * Revert "Branch point for 2020 May 30 Breaking Change"